vscode dependencies

vscode dependencies